Adaptec RAID Card with Lost SN and WWN

elohkcalb

New Member
Tried to upgrade the firmware of a 5405Z the other day using arcconf.

The upgrade failed, and that leaves me with a card that refused to show up on the boot screen. I then tried to do the upgrade using mode 0, but received a complaint instead, saying firmware I have on the USB drive doesn't match the controller. And then I applied a force upgrade with the /SkIp switch, and the upgrade went through successfully.

The card now shows up properly on boot, the array appears to be working fine, and everything seems to be operating normally. However, when I look through the config status, Serial Number field shows "FFFFFF00", and the WWN turns into something similar with only "0" and "F".

Now, according to Adaptec, there are unspecified implications of running such controller with lost SN and WWN (Source - http://ask.adaptec.com/app/answers/detail/a_id/17182/~/how-to-recover-or-properly-flash-adaptec-series-5z-controller%3F):

Note: A mode 0 flash may appear to recover the controller, but the Serial Number and World Wide Name (WWN) will have been lost and there are ramifications to running the controller without this information programmed on the controller.
Does anyone have any similar experience when performing firmware upgrade? And anyone has any idea what those "ramifications" are?
 
Top