Configure SolusVM/KVM Correctly

Mike

New Member
Verified Provider
Hey guys,

I'm having a real hard time getting a SolusVM environment using KVM, setup to use IPv6 correctly.

The IP blocks have been added to SolusVM but the guest VM's are unable to ping out or have any kind of IPv6 connectivity although they are configured correctly.

I believe the host node(s) are misconfigured but I don't have enough IPv6 experience to properly investigate the issue.

Any assistance appreciated!

Thanks, Mike.
 

KuJoe

Well-Known Member
Verified Provider
Are you able to ping out from the host node and can you ping the VPS's IPv6 addresses from the host node?
 

Mike

New Member
Verified Provider
I have IPv6 working on the host now but when I try to ping a guest or ping out of the guest I get the following;

[[email protected] ~]# ping6 2001:1b40:5000:2e::9b56:8c09
PING 2001:1b40:5000:2e::9b56:8c09(2001:1b40:5000:2e::9b56:8c09) 56 data bytes
From 2001:1b40:5000:2e::cd7:50b7 icmp_seq=2 Destination unreachable: Address unreachable
From 2001:1b40:5000:2e::cd7:50b7 icmp_seq=3 Destination unreachable: Address unreachable
From 2001:1b40:5000:2e::cd7:50b7 icmp_seq=4 Destination unreachable: Address unreachable
^C
--- 2001:1b40:5000:2e::9b56:8c09 ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4312ms

[[email protected] ~]# ping6 google.com
PING google.com(lhr14s23-in-x02.1e100.net) 56 data bytes
From 2001:1b40:5000:2e::40ae:af54 icmp_seq=2 Destination unreachable: Address unreachable
From 2001:1b40:5000:2e::40ae:af54 icmp_seq=3 Destination unreachable: Address unreachable
From 2001:1b40:5000:2e::40ae:af54 icmp_seq=4 Destination unreachable: Address unreachable
^C
--- google.com ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3700ms
 

AnthonySmith

New Member
Verified Provider
I think its to do with the ebtables update, previously enabling ip/arp protection in solusvm disabled ipv6 as it had never been configured properly for Ipv6, the solusvm-ipsecure restart is needed to alow ip6 to work since the updates.
 
Last edited by a moderator:
Top