Installation of CentosOS Web Panel on your VPS

AlphaNine_Vini

Member
Verified Provider
Before we proceed with the installation of Centos Web Panel :

 

Requirements and instructions:

At least one static IP with your VPS. (Internal IP address are not supported by this control panel)

If you wanted to remove Centos Web Panel. You need to do a reinstall on your VPS.

Install on a fresh centos Operating system.

 

Login with your VPS as 'root' user.

 

First setup your hostname

# vim /etc/sysconfig/network

Change your hostname name within this file. Your hostname will be changed after next reboot.

 

Setup your nameserver IPs

# vi /etc/nameservers

In most of VPS this is configured already. If not enter the following lines.

nameserver 8.8.8.8

nameserver 8.8.4.4 

Save the file" :wq! "

 

A static IP must be configured and provided by your VPS provider. If not contact your service provider.

 

We recommend to have at least a VPS with 4GB of ram to gain full functionality.

 

Use a Centos 6.5 version template available from your Control Panel.

 

During first installation run the following commands:

 

#yum install wget -y

#yum update -y

#reboot

 

 

After reboot, run the following commands: 

#cd /usr/local/src

#wget http://centos-webpanel.com/cwp-latest

#sh cwp-latest

 

Reboot your VPS once more:

#reboot

 

Now your Centos Web Panel will be available at 

http://<your static IP>:2030/

 

For example: http://192.168.0.2:2030/

 

1. Setup your shared IP after login.

2. Setup your one hosting package.

3. Setup your root email to receive emails.

 

Host your domains and enjoy!

 

 
 
Last edited by a moderator:

k0nsl

Bad Goy
I only glanced over the demo for a mere few seconds, and to me, that interface does look promising. However, I cannot say anything about the backend/script itself, as I haven't checked it. The design, however, did look nice and appealed to me.
 

XFS_Duke

XFuse Solutions, LLC
Verified Provider
I ran it for some sites a while back. I enjoyed it. The biggest issue I ran into was the lack of proper dedicated IP support. I eventually figured it all out, but it was just a pain. The panel itself is pretty good though, and for free, you can't expect much better. I've been toying around with the idea of setting up a preinstalled OpenVZ template, but we'll see.
 
Top