lscpd.service can’t start on Cyberpanel


New Member
Hello guys,

Yesterday the panel suddenly stopped working and I am not able to run it. Sites are online, OpenLiteSpeed is OK, but Cyberpanel is not working. When I type systemctl status lscpd.service, the server displays the following messages to me:

lscpd.service - LSCPD Daemon
Loaded: loaded (/etc/systemd/system/lscpd.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Sat 2021-03-13 08:01:14 EST; 12s ago
Process: 99672 ExecStart=/usr/local/lscp/bin/lscpdctrl start (code=exited, status=126)

Mar 13 08:01:11 3 systemd[1]: Starting LSCPD Daemon…
Mar 13 08:01:11 3 lscpdctrl[99672]: /usr/local/lscp/bin/lscpdctrl: line 71: ./lscpd: Is a directory
Mar 13 08:01:11 3 lscpdctrl[99672]: [ERROR] Failed to start lscpd!
Mar 13 08:01:13 3 lscpdctrl[99672]: lscpd: no process found
Mar 13 08:01:14 3 lscpdctrl[99672]: /usr/local/lscp/bin/lscpdctrl: line 71: ./lscpd: Is a directory
Mar 13 08:01:14 3 lscpdctrl[99672]: [ERROR] Failed to start lscpd!
Mar 13 08:01:14 3 systemd[1]: lscpd.service: control process exited, code=exited status=126
Mar 13 08:01:14 3 systemd[1]: Failed to start LSCPD Daemon.
Mar 13 08:01:14 3 systemd[1]: Unit lscpd.service entered failed state.
Mar 13 08:01:14 3 systemd[1]: lscpd.service failed.

Do you have any idea what I can do to make it work again?

I’d be infinitely grateful for any idea.


New Member
For the same query, I tried lots of ways to solve my problem but I failed. But DedicatedCore guided me perfectly and solved my problem.

If you're experiencing issues with the `lscpd.service` not starting on CyberPanel, you can follow these steps to troubleshoot and potentially resolve the problem:
1. Check Service Status: First, verify the status of the service to get more details about the issue.
sudo systemctl status lscpd.service
2. Check Logs: Review the logs for `lscpd.service` to identify any error messages.
sudo journalctl -u lscpd.service
3. Restart the Service: Try restarting the service to see if it resolves the issue.
sudo systemctl restart lscpd.service
4. Check Configuration: Ensure that the configuration files for CyberPanel and `lscpd` are correct. Sometimes, a misconfiguration can cause the service to fail.
sudo nano /usr/local/lsws/conf/httpd_config.conf
5. Rebuild Web Server: Rebuilding the web server from CyberPanel might help fix any issues related to configuration.
- Log in to CyberPanel.
- Navigate to `Server Status` -> `LiteSpeed Status`.
- Click on `Rebuild Web Server`.

6. Update CyberPanel: Ensure that you are running the latest version of CyberPanel, as updates often contain fixes for known issues.
sudo yum update
sudo sh <(curl -s
7. Check for Port Conflicts: Ensure that there are no port conflicts. `lscpd` typically uses port 8090. Verify that no other service is using this port.
sudo netstat -tuln | grep 8090
8. Permissions: Ensure that the necessary files and directories have the correct permissions.
sudo chown -R cyberpanel:cyberpanel /usr/local/lsws
9. Consult Documentation/Support: If the issue persists, consult the CyberPanel documentation or seek help from the CyberPanel community or support team.

If you want more specific details about the error messages or logs, you can contact DedicatedCore. They can give more targeted advice for your problem. Just message or call on WhatsApp: +91 9112 444404 or visit the website.
DedicatedCore will provide a solution for any panel-related issue. Thank you.