Setting up IPv6 tunnel

D. Strout

Resident IPv6 Proponent
This is a continuation of my accidentally archived thread about setting up an IPv6 tunnel. I currently am using gogoclient to accomplish this, but their servers are frequently too busy to let me tunnel through, and it just generally feels unreliable. I've tried the tunnel broker service, but it doesn't seem to want to pass through my modem, even when directly connected to it. Is there any way I can use one of my IPv6-capable VPSes to set up a tunnel all my own?

I am continuing this thread because I wasn't satisfied with the answers from the previous one and think that this is the more appropriate forum for this thread. So it's a move and a bump.
Last edited by a moderator:


New Member
It's the same thing i tried to achieve earlier but no luck, i will keep an eye on this thread see if any solution.

D. Strout

Resident IPv6 Proponent
OK, finally managed to get the tunnel IPv6 working. The biggest problem that had felled me before was that I was that I was behind NAT, and in that case when configuring the tunnel on the client you use the private NAT address (usually in the range) instead of the public IPv4 address. For example (from the second line of HE's example config for Windows Vista/2008/7):

netsh interface ipv6 add v6v4tunnel IP6Tunnel [NAT client IPv4]
By default that line will be the public IPv4 you entered to create the tunnel. Change it and you're all set. BTW, since you are behind NAT, if you need to hook up multiple clients to this tunnel, just use incrementing numbers in the "client IPv6 address" range in that third line of the example config. For instance:

#first PC
netsh interface ipv6 add address IP6Tunnel 2001:470:1f06:37f::2
#second PC
netsh interface ipv6 add address IP6Tunnel 2001:470:1f06:37f::3
That finally got the tunnel up and working, with an ipconfig /release and ipconfig /renew. I could ping ipv6 addresses and hostnames, so I was done, right? Wrong. When I tried to access in Chrome, it wouldn't work. Couldn't find the server. On a hunch, I tried Firefox. That got through. Then I found this article, which revealed that apparently, Google Chrome disables IPv6 DNS lookups by default. Go to chrome: //net-internals (remove that space there, had to add it to work around an IP.Board glitch), click the DNS tab, and click Enable IPv6. Now you're done. If you don't use Chrome, you can skip this step; the rest is the same.

Hope this helps others who were having trouble with HE's tunnel.
Last edited by a moderator: