SolusVM Patch - Solved Server Rebuild Problem Returning Error: 'Invalid Template'

Hello guys, we have just received a reply from SolusVM support with solution to common problem. This should be helpful for some of you.

{edited}
 
Last edited by a moderator:

MartinD

Retired Staff
Verified Provider
Retired Staff
Please don't link to your forums like that. If you have information to share then by all means share it here.
 
Last edited by a moderator:

Quexis

New Member
Verified Provider
From the forum in question (which I won't be linking to, due to MartinD's post above):

Important information that we received from SolusVM support. Will be helpful for many, no doubt.

This is a solution for the problem with server rebuild returning 'Invalid Template' error.

"Here is the patch you need to run on the master node in SSH:

wget http://files.soluslabs.com/solusvm/fixes/api_vserver_rebuild.txt -O /usr/local/solusvm/includes/api/api_vserver_rebuild.php
This will allow you to rebuild KVM virtual servers via the API. Example output if using the json return values would be:

{"status":"success","statusmsg":"Virtual server is being rebuilt","rootpassword":"6axLkKpi","information":"Blah\nBlah\nBlah"}Solution works on SolusVM beta only.According to the answer received from SolusVM support, it will be included in the stable version.
 
Understood, here it goes:

A few hours ago we received important information from SolusVM support regarding problem mentioned in the topic. This information should be helpful for some of you. This is a solution for the problem with server rebuild returning 'Invalid Template' error.

"Here is the patch you need to run on the master node in SSH:


wget http://files.soluslabs.com/solusvm/fixes/api_vserver_rebuild.txt -O /usr/local/solusvm/includes/api/api_vserver_rebuild.php
This will allow you to rebuild KVM virtual servers via the API. Example output if using the json return values would be:


{"status":"success","statusmsg":"Virtual server is being rebuilt","rootpassword":"6axLkKpi","information":"Blah\nBlah\nBlah"}"
According to the answer received from SolusVM support, this solution works only on SolusVM beta and it will be included in the stable version.
 
Last edited by a moderator:

rsk

Active Member
Verified Provider
Thanks for this, really. However, I guess we still have to wait for solus to release it in the stable version so we can put it into use. No BETA for me.
 
Top