KVM anomaly

H_Heisenberg

New Member
Hello vpsBoard!

I have a KVM VPS with ACPI and so on enabled in SolusVM and correctly setup in the VPS however when I run "shutdown -r now" or "reboot" the VPS shutsdown instead of rebooting. The SolusVM buttons are working correctly though because I've setup ACPI correctly. Only the two commands don't work as they are expected to work :(.

Any idea? Could it be a problem on the hostnode?
 
Last edited by a moderator:

H_Heisenberg

New Member
Where is this file located kaniini? Could you give me the path so I could look into it.

It's CentOS 6.4 by the way.
 

KuJoe

Well-Known Member
Verified Provider
The XML file will be on the hardware node so you'd have to ask your provider to check it for you.

Did you issue a reboot via SolusVM to make sure the ACPI setting saved correctly for the VPS?
 

H_Heisenberg

New Member
Yes, I did Joe.

I checked VNC and when using SolusVM buttons the right post message appears and it reboots BUT when I use the Linux commands "shutdown -r now" or "reboot" the VPS says something totally different. Actually it says it's powering off instead of going into reboot. So the two commands aren't working as the are supposed to work.

SolusVM buttons are totally ok but the rest is not.   

I checked the .xml file and it does not contain any section related to on_reboot or similar.
 
Last edited by a moderator:

H_Heisenberg

New Member
Bump.

Is there no one else who has this issue? No one who heard of similar problems? I almost forgot about this topic but then I remembered it because it happened today again when I had to reboot a VPS. The FS crashed and had to repaired. Thanks good I had journaling enabled, pfffh.
 
Last edited by a moderator:

Damian

New Member
Verified Provider
We get intermittent complaints about this from our KVM customers. Sometimes, randomly, the reboot command indeed shuts it down. This only seems to happen with Centos.

What runlevel are you on when the system is up and running?
 

Magiobiwan

Insert Witty Statement Here
Verified Provider
It seems like it's an OS Issue. What happens if you manually set init to 6?
 

H_Heisenberg

New Member
I'm very sorry for the really late replies. I've had a quite busy week in the uni with exams and a lot of other stuff to do. Now it's the last day of the weekend and I finally had time to take care of this problem.

@Damien:

It's not happening randomly. It's happening everytime this commands are being executed :(.

My runlevel when the system is up and running is

[[email protected]~]# who -r
         run-level 3  2013-07-14 11:40

@Magiobiwan:

I doubt it is a OS issue. It happens on all operating systems the provider has in form of a ISO. We're talking about Ubuntu, Debian, CentOS, Archlinux, Gentoo, Fedora, FreeBSD, etc... I've tested almost all of them when I had the time and the result is always the same. It always shuts down instead of rebooting the VPS.

I've changed init to 6 and it's still the same :<.

The provider had a kernel update about one to three weeks ago (I think so, not quite sure) but it seems it wasn't really helping. They run a alternative CentOS kernel: 3.4.* or something like that. I know it was something with the 3rd version.

Really out of clues :(.

Are these settings correct?

CADgdna.png
 

jarland

The ocean is digital
I too have noticed the issue before on one of my ramnode KVM's. My memory isn't great, but I'm fairly certain that it wasn't CentOS as quite frankly I don't believe I have ever installed CentOS on any of them. I could be wrong. I don't have much to contribute here, but definitely keeping an eye out for anything relevant.
 

H_Heisenberg

New Member
I have found out the reason for this.

It is caused by a update of SolusVM to the beta. Somewhere in between the updates SolusVM broke the .xml files and removed important entries that tell the VM how to react on "reboot", "shutdown" and so on. This is what KuJoe was talking about.

A solution could be to downgrade to stable but I am not sure whether this would work. My provider will not do it because of customized profiles of his clients (CPU host settings and so on).
 

MartinD

Retired Staff
Verified Provider
Retired Staff
Have you confirmed this with SolusVM? Sounds like a pretty annoying bug.
 

H_Heisenberg

New Member
I have looked at all of the .xml files of all KVM VMs and compared them to one of a trial SolusVM server on the stable branch.

Entries that let the VM know what to do are missing when sending commands like reboot or shutdown.
 
Top