Mail Problem VestaCP

Discussion in 'Questions and Answers' started by bluearrow, Nov 4, 2014.

  1. bluearrow

    bluearrow New Member

    5
    0
    Nov 4, 2014
    I have installed VestaCP twice now and both times mails are not working. I didn't even receive the mail you get when installation finish. This happened twice in different servers so I must be something to do with my installation.

    Didn't do anything different. Just follow basic installation instruction which available many hosting related sites. Server has 1GB RAM.

    1) How do I make sure provider hasn't blocked mail ports or something that ?

    2) Do we need rDNS to get mail working in Vesta ?

    3) Do I need to install anything else like installing any other applications ?

    Tried so many things but none has worked yet. Screen print from mxtoolbox when I tested for email server

    32zqmmu.jpg
     
    Last edited by a moderator: Apr 30, 2017
  2. Geek

    Geek Technolojesus Verified Provider

    404
    229
    May 31, 2014
    __geek__
    That's odd to not even have the install details sent over.  What's in /var/log/exim/main.log (or) reject.log ? It would probably be a good idea to set the RDNS but I doubt it would make a difference like that right off the bat.
     
    Last edited by a moderator: Nov 4, 2014
  3. HalfEatenPie

    HalfEatenPie The Irrational One Retired Staff

    2,890
    1,386
    Mar 25, 2013
    HalfEatenPie
    Open a support ticket with your provider.

    Honestly the rDNS is required if you're planning on using it as a mail server. While rDNS isn't 100% required on the first "installation successful!" email (because the first email should technically go through), I'd check with the email block lists to see if your IP is blacklisted.

    VestaCP should already have taken care of this for you.

    General rule of thumb, like what @Geek said, check your logs. That's always the first step to any problem, your logs will help you solve this problem. In addition, check your spam/junk folder with your email provider. Majority of the time, it'll probably be in there. If this is a VPS with any of the ColoCrossing sub-brand, then you're SOL. Again, check to make sure if your IP is in a blacklist and if it is, more than likely you really shouldn't be with that provider.
     
  4. bluearrow

    bluearrow New Member

    5
    0
    Nov 4, 2014
  5. wlanboy

    wlanboy Content Contributer

    2,126
    1,169
    May 16, 2013
    How do your DNS entries for the domain look like?

    What server is set as the DNS server for the domain?

    Maybe it is a timing problem because you switched the DNS server?
     
  6. bluearrow

    bluearrow New Member

    5
    0
    Nov 4, 2014
  7. bluearrow

    bluearrow New Member

    5
    0
    Nov 4, 2014
    I installed again in 2 servers and it worked in one and didn't work in another. Didn't even received installation completed mail from server it didn't work.

    http://www.intodns.com/gilles-desblancs.info

    This shows " ERROR: No reverse DNS (PTR) entries. ". Do I need to contact porvider for this or can it be done through SolusVM ? I noticed it has a option for rDNS but I have no idea how to use it.