VestaCP error when sending email with thunderbird

thekreek

Member
Hello, I have a small issue with VestaCP, not sure if you have had the same problem before.

I'm trying to send email with thunderbird as my email client, the message I'm getting its the following:

An error occurred while sending mail. The mail server responded: Helo name contains a ip address (HELO was [192.168.1.50]) and not is valid. Please verify that your email address is correct in your mail preferences and try again.

I double checked the settings in thunderbird:

IMAP: mail.domain.com - port 143 - STARTTLS - Normal password

SMTP: mail.domain.com port 587

Thunderbird is able to download the email without a problem, the only thing I added to my VestaCP install was CSF following the instructions from Steven's blog

I have done the following:

* Change the LAN IP from the computer (wifi and wired)
* Disable CSF (same error)

Do you have any suggestions or tips?

vestacp iniz email error local ip.png
 

wlanboy

Content Contributer
Did your vps does have a valid hostname?

And does your email client use auth for SMTP?

An option like: "Outgoing server requires authentication, use same settings as incoming server"?
 

mikho

Not to be taken seriously, ever!
The mailserver replies to the HELO command with an internal IP which is apparently is not accepted by Thunderbird.


Is there an option to make the mailserver return the domain name in the HELO command?


In MS Exchange its called a masquerade domain, most be the same here or a similar name.
 

thekreek

Member
Yes I'm using authetication on thunderbird.

The issue appears to be from exim4, the logs show the same error. Currently I'm looking on the exim docs to see if I'm able to fix it, so far I haven't hit the jackpot.

Yes it has an FQDN.
 

switsys

Active Member
The mailserver replies to the HELO command with an internal IP which is apparently is not accepted by Thunderbird.


Is there an option to make the mailserver return the domain name in the HELO command?


In MS Exchange its called a masquerade domain, most be the same here or a similar name.
It seem to be the complete opposite. :p


The client (Thunderbird) announces itself with the local IP, which is not accepted by the mail server.

Yes I'm using authetication on thunderbird.

The issue appears to be from exim4, the logs show the same error. Currently I'm looking on the exim docs to see if I'm able to fix it, so far I haven't hit the jackpot.

Yes it has an FQDN.
I think the problem could be related to exim not being configured to allow "domain/address literals" (RFC2821) and (RFC1123).

Theoretically you should be able to resolve this by adding the line ALLOW_DOMAIN_LITERALS in the main exim config file, or MAIN_ALLOW_DOMAIN_LITERALS = yes in a 'local' configuration file.

Or by editing OR commenting out the lines in the ACL that says 'deny' and 'drop' regarding 'acl_smtp_mail'.
 

mikho

Not to be taken seriously, ever!
It seem to be the complete opposite. :p


The client (Thunderbird) announces itself with the local IP, which is not accepted by the mail server.
That was sort of what I ment but messed up while thinking and typing at the same time.


Exim reply with the ip that Thunderbird says it comes from.


You need to either make Thunderbird use the external ip or (as posted on LET) edit the exim conf to allow internal ips.
 

switsys

Active Member
That was sort of what I ment but messed up while thinking and typing at the same time.


Exim reply with the ip that Thunderbird says it comes from.


You need to either make Thunderbird use the external ip or (as posted on LET) edit the exim conf to allow internal ips.
It doesn't matter if Thunderbird 'uses' the external IP or not.  


It has nothing to do with whether the address is 'internal' or 'external'.


It's about 'allowing' the usage of IP-addresses, ANY IP-address AT ALL, instead of DNS-names ( i.e. '[email protected]' instead of '[email protected]' ).
 

mikho

Not to be taken seriously, ever!
It doesn't matter if Thunderbird 'uses' the external IP or not.


It has nothing to do with whether the address is 'internal' or 'external'.


It's about 'allowing' the usage of IP-addresses, ANY IP-address AT ALL, instead of DNS-names ( i.e. '[email protected]' instead of '[email protected]' ).
It does matter, if Thunderbird reports an internal IP and Exim doesn't allow it then there is a problem.


So, to solve it you need to change something on either the client or server, or both.
 

wlanboy

Content Contributer
Yes I'm using authetication on thunderbird.

The issue appears to be from exim4, the logs show the same error. Currently I'm looking on the exim docs to see if I'm able to fix it, so far I haven't hit the jackpot.

Yes it has an FQDN.
Check your SMTP setting within Thunderbird.

You can define a user name for each SMTP account.

Maybe Thunderbird will not add the ip If you add the domain there:

 
Last edited by a moderator:

jarland

The ocean is digital
It doesn't matter if Thunderbird 'uses' the external IP or not.  


It has nothing to do with whether the address is 'internal' or 'external'.


It's about 'allowing' the usage of IP-addresses, ANY IP-address AT ALL, instead of DNS-names ( i.e. '[email protected]' instead of '[email protected]' ).
If things are set well it does. Most people tend to limit traffic that declares itself as  RFC1918 address space outside of a local network.
 
Top