Audio on my Linux PC?

MannDude

Just a dude
vpsBoard Founder
Moderator
Been struggling with this one. My system detects my soundcard, yet, here I sit with no sound. Screenshots and command outputs below:

Egmh40m.png

Ran:

alsamixer3RUqgpr.pngVCprgW4.png

LryMjRz.png

pjufSO7.png

GrnyicN.png

~$ cat /proc/asound/cards

0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfce78000 irq 21
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfe9ec000 irq 42
2 [CA0106 ]: CA0106 - CA0106
Audigy SE [SB0570] at 0xac00 irq 16
Code:
~$ lsmod|grep snd

snd_ca0106             38027  2 
snd_ac97_codec        106942  1 snd_ca0106
snd_hda_codec_hdmi     30824  2 
snd_seq_midi           12848  0 
snd_seq_midi_event     13316  1 snd_seq_midi
snd_hda_intel          26259  2 
snd_rawmidi            23060  2 snd_seq_midi,snd_ca0106
snd_hda_codec          78031  2 snd_hda_intel,snd_hda_codec_hdmi
snd_hwdep              13186  1 snd_hda_codec
snd_pcm                68083  5 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_ac97_codec,snd_ca0106
snd_page_alloc         13003  3 snd_pcm,snd_hda_intel,snd_ca0106
snd_seq                45126  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         13176  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              22917  2 snd_seq,snd_pcm
snd                    52889  19 snd_timer,snd_seq_device,snd_seq,snd_pcm,snd_hwdep,snd_hda_codec,snd_rawmidi,snd_hda_intel,snd_hda_codec_hdmi,snd_ac97_codec,snd_ca0106
ac97_bus               12510  1 snd_ac97_codec
soundcore              13065  1 snd
Upon request I did this:

Code:
nano $HOME/.asoundrc
 And made this:

pcm.!default {
type hw
card 2
device 3
}
Code:
~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 0: ca0106 [CA0106]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 1: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 2: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 3: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 
Code:
~$ sudo cat /proc/asound/cards

 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfce78000 irq 21
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe9ec000 irq 42
 2 [CA0106         ]: CA0106 - CA0106
                      Audigy SE [SB0570] at 0xac00 irq 16
 
And here I continue to sit, without audio.
 
Last edited by a moderator:

Tux

DigitialOcean? lel
I do not know why you have 3 sound cards...


which card are you trying to get output on?


office Android voice recognition sucks! (Not my words...)
 

MannDude

Just a dude
vpsBoard Founder
Moderator
I do not know why you have 3 sound cards...


which card are you trying to get output on?


office Android voice recognition sucks! (Not my words...)
I'm not 100% sure why either, this was a custom build that was given to me by an old room mate who moved onto a bigger beast of a PC. I've just now recently been utilizing the machine as I hate working from my laptop.

There is a dedicated sound card, which I assume to be the SoundBlaster. That is the one I am trying to get to work. No sound outputs on the motherboard, though there is sound outputs on the front of the machine though I can't be bothered to turn everything off and open it up to see if they're connected to anything or if they're just part of the case. All I know is they also don't work.
 

Ivan

New Member
Verified Provider
Was it on Linux before he gave it to you? It could be some missing drivers or so, but I can't tell exactly because I don't know how to work with Linux desktops :p Though the from jacks would work, try the front ports.
 
Last edited by a moderator:

MannDude

Just a dude
vpsBoard Founder
Moderator
Was it on Linux before he gave it to you? It could be some missing drivers or so, but I can't tell exactly because I don't know how to work with Linux desktops :p Though the from jacks would work, try the front ports.
Nah, he's a glorified Windows user. I've been using Linux as a desktop off/on for going on six or seven years now, with at least the last 4 being strictly Linux. I've never had an issue with Linux detecting hardware devices or using them properly in the past.

Now, through some randomness I loaded a video on YouTube via Chrome. I didn't need to hear it, but then I could hear... sound. I had my headphones plugged in. Put them on and sound was there!

Prior to this I was just using Firefox to try to hear audio via YouTube, which still doesn't work. But audio works fine via Chrome. Not sure if VLC or any desktop programs play sound appropriately, I have no MP3s or video files locally anymore.
 

mikho

Not to be taken seriously, ever!
There must be someplace where you can set a default port for the audio?!

I've never had a linux desktop with 3 soundcards so I can't relate to your problem, I do have a laptop with audio output (goes to my speakers) AND a 3.5 mm headphone output.

I can (in windows) select which should be the default and in some apllications I can select which outputs to use (like my sip phone).
 

drmike

100% Tier-1 Gogent
There must be someplace where you can set a default port for the audio?!

I've never had a linux desktop with 3 soundcards so I can't relate to your problem, I do have a laptop with audio output (goes to my speakers) AND a 3.5 mm headphone output.

I can (in windows) select which should be the default and in some apllications I can select which outputs to use (like my sip phone).
I have the multiple soundcard detect issue all the time on my various notebooks.  Seems to be common on Debian and derivatives.

Browsers and sound on linux are spotty at best.  Chrome (which I kind of hate) comes out of the box post install with Flash installed or open source equivalent.   Opera, my favorite requires manual hacking to get the flash plugins working.

I try to avoid running any media in the browser as it tends to be a big hassle, browser crashes, slow, etc.

I hacked a CLI bash script eons ago that I can't find, utilizing youtube-dl to download a file I want to watch on YouTube and playing it on the fly.  It's simple and nice with a bit of initial delay, but nothing bad.  Nice cause the commercials YouTube seems to be full of these days aren't in the youtube-dl files :)
 

acd

New Member
Try the following:


pactl exit


mkdir ~/.pulse


echo 'autospawn=no' >> ~/.pulse/client.conf


Then log out and log back in. Kill any esound processes that might be running. Make sure pulse is off too. Then tryto play any audio and check your playback volume/settings. Pulsesudio is probably the world's least user friendly audio framework.


If that works, check the log files for pulse if/when you re-enable it. Odds are some other sound source is fighting for the sink and your application doesn't win.
 

Shados

Professional Snake Miner
Screenshot of the 'configuration' tab on pavucontrol would be helpful - often this kind of thing results from having the wrong profile selected for a given device. Also, for Flash (and other programs that don't directly support PulseAudio and just use ALSA) you need a correctly-configured /etc/asound.conf or ~/.asoundrc file, although most distributions include one in the pulseaudio package or a related package.
 
Top